Instalando o PSE no Ubuntu 7.10 Gutsy Gibbon

O novo Ubuntu[bb] 7.10 está maravilhoso. Até o 7.04 eu usava um hack para fazer funcionar minha placa de rede, agora ela funciona sem truques. O compiz já instalado funcionou sozinho, bem direitinho. O resto tudo também funcionou sem dor. Menos o PSE.

Por algum motivo estranho, a versão do mod_python (3.3.1) desse novo Ubuntu reclama de sei lá o que. A versão anterior (3.1.3) funcionava sem problemas. Dei um jeito aqui de colocar para funcionar. Não sei se é uma boa saída, se alguém tiver uma sugestão melhor, por favor.

Segue a receita de bolo para instalar o PSE no novo Ubuntu:

  1. Instale os pacotes necessários: sudo apt-get install apache2 libapache2-mod-python python-profiler build-essential latex2html
  2. Baixe o PSE: wget http://nick.borko.org/pse/PSE-3.0.6.tar.gz
  3. Extraia o código fonte: tar -xzvf PSE-3.0.6.tar.gz
  4. Entre na pasta: cd PSE-3.0.6
  5. Compile e instale: sudo python setup.py install
  6. Edite o arquivo de configuração do Apache: sudo gedit /etc/apache2/apache2.conf
    Acrescente ao final:
    PythonHandler pse_handler
    AddHandler python-program .pt
  7. Aqui vai o hack: sudo gedit /usr/lib/python2.5/site-packages/mod_python/importer.py
    Encontre a linha 303, que deve ser:
    return __import__(module_name, {}, {}, '*')
    E edite para ficar:
    return __import__(module_name, {}, {}) #, '*')
    Cuidado para não quebrar a identação!
  8. Reinicie o Apache: sudo invoke-rc.d apache2 restart

Pronto, deve funcionar. Aqui para mim foi só isso.

Publicado por

Elcio

Elcio é sócio fundador da Visie Padrões Web. Pioneiro no uso e divulgação dos padrões do W3C no Brasil, Elcio já treinou equipes de dezenas de empresas como Globo.com, Terra, Petrobras, iG e Locaweb. Além disso, tem dirigido as equipes da Visie no desenvolvimento de projetos web para marcas como Brastemp, Itaú Unibanco, Johnson & Johnson e Rede Globo.

8 comentários em “Instalando o PSE no Ubuntu 7.10 Gutsy Gibbon”

  1. Elcio, tudo bem?

    Utilizava o PSE no ubunto 7.10 e migrei agora para o ubuntu 9.10 e ele não funciona mais. Estou tendo um problema que toda vez que passo um form via pse que possui algum caractere acentuado dá UnicodeError.

    Verifiquei e o erro é dentro da função normalize do form.py da pse_handler na hora de dar um encode para UTF-8.

    Você já pegou esse erro?

    Obrigada!

  2. Elcio, também utilizo o Ubuntu 7.10 e aqui só consegui fazer o PSE funcionar com o hack que você mencionou… Como conheci o PSE hoje (!) ainda não tenho nenhuma sugestão melhor para resolver o problema, mas se tiver lhe notifico.

    Ótimo post 😉

  3. Eu curti o 7.10. Nunca fui um usuário assíduo de Linux. Quando lançam uma nova versão do Ubuntu eu baixo, queimo e instalo, fico uma semana e volto para o Windows. Mas vi que o Ubuntu em particular é uma distribuição que está melhorando muito desde a versão 5.10 (que é desde onde eu acompanho). Instalar programas também não é mais tão difícil depois que se aprende a usar os comandos básicos do bash.
    Quem sabe daqui a 6 meses, quando sair a próxima versão, eu não tento de novo ;D

  4. Jader,

    Não, meu problema não é o mesmo. Meu mod_python.load existe. Deve ter havido algum problema durante a instalação do pacote libapache2-mod-python aí, não?

    O melhor é que você tente reinstalar o pacote. Se não conseguir e quiser criar ele à mão, o conteúdo é uma linha só:

    LoadModule python_module /usr/lib/apache2/modules/mod_python.so

  5. O problema que tive (e ainda não resolvi) com o mod_python é que o arquivo /etc/apache2/modules-enabled/mod_python.load (que é um link simbólico para /etc/apache2/modules-avaible/mod_python.load) está quebrado, simplesmente porque, por um motivo obscurto que eu ainda não entendi, o arquivo que está sendo linkado não existe.

    Talvez seu problema com o PSE seja o mesmo. 😉
    Quando eu chegar em casa eu vejo se pra mim funciona também.

  6. Cara,

    No meu note já é o oposto, no Ubuntu 7.10, minha placa de rede nao funciona nem rezando.

    Estou ainda no 7.04 e vou ficar nele por muito tempo.

    Se tiver alguma dica mada aí, meu note é um Toshiba 2430-S255

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *